cPanel/WHM

Install LiteSpeed in cPanel/WHM with Obsolete Owned License

If you have Obsolete Owned LiteSpeed License, installation via cPanel plugins will not work. There will be an error like

[ERROR] You are not authorized to use this binary, please purchase upgrades

If you encounter this error, then you have to manually install authorize old version of LiteSpeed. This is the guides on how to do it.

1. Log in to LiteSpeed Client area and check license update expiry date. In LiteSpeed Release Log Page, find LiteSpeed version that you can use.

2. SSH to your server & download and extract the applicable version (example below for version 4.2.6)

cd /home
wget http://www.litespeedtech.com/packages/4.0/lsws-4.2.6-ent-x86_64-linux.tar.gz
tar zxf lsws-4.2.6-ent-x86_64-linux.tar.gz
cd lsws-4.2.6

3. create a file with name serial.no, edit the file & copy license information into the file and save.

nano serial.no

4. Proceed with LiteSpeed installation

sh install.sh

5. Accept the License Agreement by typing – Yes

6. Specify installation directory – /usr/local/lsws

7. Installer will generate license key & exit.

8. Run the installer again, accept the licence agreement & specify installation directory as of step 4 to 6 above.

9. Enter username – admin

10. Enter your choosen password

11. Enter admin email address

12. Enter “1” for cPanel installation

13. Enter Port Offset “0” for replace Apache

14. Enter “1” to enable PHP suEXEC

15. Installation will start

16. Enter “Y” to enable LiteSpeed start automatically when server start

17. Enter “Y” to start LiteSpeed.

18. Is start failed, login to WHM. Under Plugins  LiteSpeed, Click compile matching LSPHP binary.

19. When LSPHP compilation complete, try to restart Litespeed

20. Is the start failed, click on Version menu & force re-install the same version or older version.

21. LiteSpeed should be running now.

Fix cPanel cpmove “Cannot restore. That user already exists on this system”

I’m trying to restore user cpmove backup file in cPanel/WHM system but the following error message come out

Cannot restore. That user already exists on this system

The first step is to check whether the similar username already exist. If it is, you have to terminate the similar account.

If you have the same problem as me where the similar username does not exist or already terminated, but the same error came out, you need to force restore.

To do this, you need to log-in to SSH as root & issue the following command

/scripts/restorepkg --force [username]

Make sure the cpmove file already in /home directory.